Advance - US Region - 502 Bad Gateway Errors

Incident Report for Gravyty

Postmortem

A system outage occurred when a routine resource scale-up triggered an unexpected de-provisioning of our environment by AWS. Services are now stable. We are currently investigating the underlying cause with AWS support to ensure this does not recur.

Posted Apr 08, 2026 - 15:18 UTC

Resolved

Our engineers have identified a load spike in the US region causing 502 Bad Gateway errors across the region.
Posted Apr 07, 2026 - 16:30 UTC