Raise: Temporary Raiser's Edge NXT Data Load Disruptions Due to Microsoft Outage

Incident Report for Gravyty

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 13:07 UTC

Monitoring

Notice: Microsoft is experiencing a widespread outage affecting Azure services used by Blackbaud authentication. Raise clients integrated with Blackbaud may see temporary data load failures. We’re monitoring the issue and will automatically re-run failed loads once service is restored.
Posted Oct 29, 2025 - 20:22 UTC
This incident affected: Raise (Raise Prompts - US Region, Raise Prompts - CA Region, Web App & Database - US Region, Web App & Database - CA Region, Data Loads & Writebacks - Raiser's Edge NXT).